1. Registration trouble? Please use the "Contact Us" link at the bottom right corner of the page and your issue will be resolved.
    Dismiss Notice

67 cj5 ready to start questions

Discussion in 'Early CJ5 and CJ6 Tech' started by pilebuck, Oct 18, 2010.

  1. Oct 18, 2010
    pilebuck

    pilebuck Member

    western WA.
    Joined:
    Apr 28, 2008
    Messages:
    239
    Done with wiring tub back on never touched the engine except for intake manifold gasket.2BBL rochester is rebuilt new plug wires.Jeep sat for about two yrs new fuel lines.Should i have to prime the fuel system carb,pump etc? Weak spark also delco distrubator new ballist resistor ,and coil.Would the points or condenser go gunney bag from sitting ?Never took distrubator out it was running when i started this project.Put testing light to pos side of coil and have power going to coil ?? any sugestions would be great thanx :):v6::flag:
     
  2. Oct 18, 2010
    John Worman

    John Worman from New Mexico

    La Luz, New Mexico
    Joined:
    Sep 22, 2002
    Messages:
    118
    I have a 67. It's never set for 2 years, and it has an electric fuel pump, so anything I say may be completely invalid.

    It would be nice to get the oil pressure up before starting, but that would mean pulling the distributor. If you can fill the carb with gas, the starting will go a lot faster. On the other hand, if you crank for a while it may move some oil while it's filling the carb with gas.
     
  3. Oct 18, 2010
    nickmil

    nickmil In mothballs.

    Happy Valley, OR
    Joined:
    Sep 23, 2002
    Messages:
    12,123
    I'd suggest priming the oil pump first. Since you have a 2 barrel rochester I'm assuming you have a Buick V-6. They have an external oil pump that over a long period of time can "drain back". Without oil in the pump it can't create suction and pick up oil from the pan and prime. I'd suggest removing the oil filter adapter and packing it with vaseline first or at least removing the distributor and use a tool to prime the engine. Went through this recently with another guy.
    Check the points. Very possible they corroded while sitting.
     
  4. Oct 19, 2010
    pilebuck

    pilebuck Member

    western WA.
    Joined:
    Apr 28, 2008
    Messages:
    239
    Thanks yes it is a 225 got it primed and put fuel in carb she ran.But after the gas prime was gone no start.I pulled off the inlet hose at the fuel pump and turned her over no gas coming out have 3 gal in tank under seat.I was sure when i pulled the line going to carb i would get gas yes no ?? thank you all the help is great.
     
New Posts