1. Registration trouble? Please use the "Contact Us" link at the bottom right corner of the page and your issue will be resolved.
    Dismiss Notice

Headlight switch and alternator problems?

Discussion in 'Early CJ5 and CJ6 Tech' started by russo, May 18, 2008.

  1. May 18, 2008
    russo

    russo Hope is not a method

    Norris, Tennessee
    Joined:
    Oct 28, 2005
    Messages:
    498
    I was out yesterday evening and had a problem with the alternator and headlight switch - I think.

    Since I finished reassembling the 5 about two years ago, I have noticed that every time I turn on the headlight while the jeep is in motion it will miss one time as if for a split second all the power to the system had been lost. After that it runs fine and the lights work fine.

    Coming home last night, I switched on the lights and the alternator light came on and stayed on. The Alt light goes out when the lights are turned off.

    It's got a new HL switch and a fairly new alternator.

    Any thoughts on what the cause might be? A short or ground issue?

    Not sure where to start looking.
     
  2. May 18, 2008
    Txjake

    Txjake I wrenched with Sparky

    Oklahoma City OK
    Joined:
    Feb 3, 2006
    Messages:
    544
    might be a ground. also, have you tested the output on the alternator?
     
  3. May 18, 2008
    farfle

    farfle old dog

    Mariposa, CA
    Joined:
    May 14, 2007
    Messages:
    430
    I always ground the alternator using a dedicated wire from the alt to a common ground point. Without it the only chance your alt has to find a ground is through the mounting bolts to the bracket to the block. Lots of places to lose or get a weak ground due to grease, rust corrosion, etc. Worth a try, it's quick and easy to do.

    I also ground the starter case directly to battery, ground distributor, front shell, and body. Redundant grounds never hurt, especially on a jeep. Clears up a lot of oddball problems, goofy blinkers, etc.
     
  4. May 18, 2008
    Walt Couch

    Walt Couch sidehill Cordele, Ga. 2020 Sponsor 2019 Sponsor

    cordele, Ga.
    Joined:
    Mar 29, 2007
    Messages:
    5,466
    If you are having pblms with your gauges also, the speedo group has lost ground at dash panel or panel ground bad to tub or tub to frame or frame to battery. (or all of these) Symptom on alt light comes on, is due to back feed. Cause---Bad Ground.
     
  5. May 19, 2008
    russo

    russo Hope is not a method

    Norris, Tennessee
    Joined:
    Oct 28, 2005
    Messages:
    498
    Thanks guys. You have helped me develop a plan of attack.
     

Share This Page

New Posts