1. Registration trouble? Please use the "Contact Us" link at the bottom right corner of the page and your issue will be resolved.
    Dismiss Notice

Engine runs ``square``

Discussion in 'Intermediate CJ-5/6/7/8' started by BobFortier, Sep 15, 2006.

  1. Sep 15, 2006
    BobFortier

    BobFortier Member

    Joined:
    Nov 24, 2005
    Messages:
    254
    Hi all

    Last weekend I had this trail ride. it involved some water passage, slimmy mud and all. When I came back, the engine was running rougher than usual, but I tought at the time the it simply going this way because it had runned 6 hours at nearly idle.

    But no, tonight I took the jeep to go to the weekly meeting at the club. The engine is running ``square`` I'm sure you know what I mean. It misses power, does not run great, and shake badder than usual. I remarked that my distributor cap was loose last saturday, and I rolled some time before seeing this. Did my cap got worn unevenly during that time ? Is there water somewhere ? is there such thing as mud entering the bellhousing and de-balancing the engine ?

    Opinion on this please !!

    Thanks to all for your usual help !!


    Bob in Sherbrooke, Province of Qu├ębec
     
  2. Sep 15, 2006
    Patrick

    Patrick Super Moderator Staff Member

    Los Alamos, NM
    Joined:
    Sep 22, 2002
    Messages:
    8,360
    Sounds like water in the distributer cap... Take it off, spray it out with some non flam. brake cleaner or the like, and wipe it out with a dry cloth....
     
  3. Sep 15, 2006
    jeepdad

    jeepdad Member

    chowchilla,...
    Joined:
    Jul 15, 2006
    Messages:
    97
    x2, possible moisture in cap.
     
  4. Sep 16, 2006
    Geeper

    Geeper New Member

    Lake Tahoe,...
    Joined:
    Sep 10, 2006
    Messages:
    13
    x3, start at the cap.
     

Share This Page

New Posts