1. Registration trouble? Please use the "Contact Us" link at the bottom right corner of the page and your issue will be resolved.
    Dismiss Notice

Novak Hydraulic Clutch On 225 W/t90

Discussion in 'Early CJ5 and CJ6 Tech' started by shaun, Sep 16, 2020.

  1. Sep 16, 2020
    shaun

    shaun Member

    ohio, Beavercreek
    Joined:
    Oct 15, 2015
    Messages:
    263
    Anyone install the Novak hydraulic clutch on their CJ? I’m having issues with my clutch going into gear.. I have new slave/MC/fork/flywheel or pressure plate. All installed and it’s very spongy, no pressure to push pedal. I bled the lines and it seemed to have some pressure but days later I tried to run the Jeep for first time in 4 yrs since rebuilding it and upgrading. Called Novak and he said after bleeding I should push the plunger on slave all the way in to reset piston....anyone had any issues? I even put a spacer between the bellhouse and slave but now it seems the fork moved too far and fluid is coming out of rubber dust cover. Jeff said to push plunger to reset piston and it should fix issues. Any help on this would be great. Going t try jeff from Novak’s idea this Thursday.
    Shaun
     
  2. Sep 17, 2020
    Warloch

    Warloch Did you say Flattie??? Staff Member

    Falcon, CO
    Joined:
    Mar 4, 2003
    Messages:
    4,751
    I've got one in my 225/SM465 setup. Never run into the issue your talking about though. I simply bled the system at install and haven't had issues since with it.
     
  3. Sep 17, 2020
    Rich M.

    Rich M. Shoe pusher

    Maryland
    Joined:
    Mar 23, 2008
    Messages:
    823
    Master appropriately sized and bench bled?
     
  4. Sep 17, 2020
    rejeep

    rejeep Well-Known Member 2020 Sponsor 2019 Sponsor

    Rochester, NY
    Joined:
    Nov 5, 2009
    Messages:
    1,579
    the seal on the plunger prob got distorted if it shot out of the bore.. I would say try Novaks suggestion first
     

Share This Page

New Posts