Fino's 1970 Mini Build Thread

Discussion in 'Builds and Fabricators Forum' started by FinoCJ, Oct 3, 2014.

  1. Mar 16, 2017
    tarry99

    tarry99 Member Sponsor

    Northern California
    Joined:
    Oct 29, 2012
    Messages:
    3,139
    Lucky he's in Colorado already.............Coming from Cally..........pistol grip ,forward grip , Semi auto , more than 10 rounds will get you a court appearance here............
     
  2. Mar 16, 2017
    Rozcoking23

    Rozcoking23 RUN & GET BIT! Sponsor

    Stockton, CA
    Joined:
    Mar 29, 2008
    Messages:
    379
    your right about that....except hes active Military....he gets to enjoy his toys!
     
  3. Mar 16, 2017
    tarry99

    tarry99 Member Sponsor

    Northern California
    Joined:
    Oct 29, 2012
    Messages:
    3,139
    Hey Rob, Is that transport only?
     
  4. Mar 16, 2017
    FinoCJ

    FinoCJ 1970 CJ5 Sponsor

    Denver, CO
    Joined:
    Jul 18, 2013
    Messages:
    1,100
    I think technically he may only transport them - when in SD I think he is supposed to keep them on base (?). I don't think any of them actually do, and in many situations I think having active military status provides a bit of unofficial leeway from the authorities. As he definitely can't shoot them on public land in california, he was excited to take advantage of colorado. And it may very well be the only time I get to experience shooting such stuff... In addition to the more tactical ARs there was some unusual large caliber (.50) firearms that are more for show or discussion (and experience the kick) that we also shot a few rounds from. I am not much of a 'gun person' - whatever that means - but it was a fun and safe day. Even my wife is actually interested to do some more .22 target shooting - which is exactly what I like doing ever so often.
     
    dieseljeeper likes this.
  5. Mar 16, 2017
    Rozcoking23

    Rozcoking23 RUN & GET BIT! Sponsor

    Stockton, CA
    Joined:
    Mar 29, 2008
    Messages:
    379
    As active Military he can transport in and out of state without registering them as assault weapons. Still can't possess the high cap mags, regardless.
     
  6. Apr 18, 2017
    FinoCJ

    FinoCJ 1970 CJ5 Sponsor

    Denver, CO
    Joined:
    Jul 18, 2013
    Messages:
    1,100
    So I am still struggling to get my rebuilt engine tuned in right. I have been mostly focusing on my 2g carb: initially it was running way too rich (would only idle with idle screw all the way in and closed), but with a second cleaning (especially the power valve area), new power valve, and reseating the main passageway check ball its much better. I think I was getting fuel leaking through the main passageway at all times. The throttle screw can be backed way off, and the idle screws actually function in terms of adjustment. Recheck point dwell (been holding off on reinstalling pertronix ring until it running right on points), reset initial timing etc. The distributor is a new Cardone rebuilt unit with new vac can, points and condenser.

    Actually I thought I had it running great - at least in the garage with no load on the engine. Took it out for a drive...have the dreaded stumble when accelerating hard. Under my normal non heavy footed driving it might not even be noticed - I can get it up to plenty high rpm as long as I don't floor it totally. But when flooring it...a big choke and stumble before it picks up. I can't reproduce the stumble in the garage under no load, but I do hear a delayed 'gulp' or whoosh of air flow into the carb when operating the throttle aggressively by hand. Its not enough to cause a stumble, but guessing under load its causing the issue. Plus I don't remember it sounding like that before the rebuild - it was a smoother, immediate inflow of air. But I also have a different cam now (comp cam with the 252 grind for 1000-4000rpm range: 63-234-4) - not sure what affect that might be having. The accel pump is new and working great in terms of looking at it squirt two nice streams of fuel and the manual choke flap is staying open. After driving it around just a bit, and even with some idling for tuning, the plugs seemed just a bit too grey-white and thus running a bit lean. This would indicate a limited fuel issue as opposed to an air issue...? I am running the 49 main jets - standard for 5000ft just as it was before the rebuild. Arghh, carbs are simple, but they are not....
    1) a delayed pull of inflow air due to a vacuum leak?
    2) The new power valve is not letting enough fuel through? I didn't replace the power piston - so maybe its sticking a bit and not pushing down and opening to PV fast enough?
    3) Maybe my float is a bit too low not allowing enough fuel in the bowl? I set my brass float to 1 5/32" using the middle seam on the end of the float, and drop to 1 7/8" again using middle seam - both with gasket in place. But, when doing to the upper float setting, the float is not all that horizontal. Maybe just a bit more fuel in the bowl would allow both the accel pump to squirt just a bit more fuel or allow just a bit more fuel in through the PV?
    4) Am i somehow loosing spark (too much advance and the dwell is too short?)

    Finally, although its probably not perfect, I think the dwell and initial timing are in pretty good shape. Dwell sits right at 30 and I have moved the initial timing around using both my ear and vac gauge - but have it tentatively set it at 8 BTDC. I think it actually likes 10-12 BTDC more, but was I running it at 5 BTDC previously (before rebuild with old cam) and didn't want to get too far out of hand just yet, and it seemed to have some harder starting so i backed it off. So far I get the stumble no matter what the initial timing is set at. Obviously, at Denver's high elevation it can be more advanced, but not sure how much affect the new cam might have. Can anyone running the 252 comp cam give any input into how it might affect timing - definitely seems to like more advance at idle. Also seems to like just a bit higher idle rpm - or lets say its gets kind of rough below 700rpm - seems to like 720-730 as opposed to 650 before the rebuild.

    Maybe I should try the t-shirt trick over the top of the carb and try to choke it down hard at rpm and maybe clean out some sort of blockage?

    Anyone want an old jeep...Julius I'll trade you for yours when you get FI installed.
     
    Last edited: Apr 18, 2017
  7. Apr 18, 2017
    FinoCJ

    FinoCJ 1970 CJ5 Sponsor

    Denver, CO
    Joined:
    Jul 18, 2013
    Messages:
    1,100
    Edit - was thinking this current thread 2g Grief might be related, but all seems good along those lines. I get hesitation and choke down when going from half throttle hard to full throttle.

    Drove around a bit more this afternoon and am going to pull the plugs see if they still look lean. I truly think its lacking fuel when under hard acceleration. I pulled the the manual choke out a bit and it seems to significantly reduce the bog down to more of a slight hesitation - so maybe it just needs more fuel.

    Would the new comp cam require slightly larger main jets? Since this stumble only occurs under acceleration seems like its more related to PV and or accel pump. Not sure how to test a power valve and piston...may try to raise the float a bit...
     
    Last edited: Apr 18, 2017
  8. Apr 18, 2017
    Warloch

    Warloch Did you say Flattie??? Staff Member Sponsor

    Falcon, CO
    Joined:
    Mar 4, 2003
    Messages:
    4,160
    I would think PV and pump. I never ran that cam with a stock 2G, only 4bbls (390 and TA 470s - well and now with EFI). The vacuum curve will be different in it as well.
     
  9. Apr 19, 2017
    FinoCJ

    FinoCJ 1970 CJ5 Sponsor

    Denver, CO
    Joined:
    Jul 18, 2013
    Messages:
    1,100
    Thanks Chuck - continuing to make progress. I pulled the PV and cleaned up under it again some more. Did the same with the power piston (which certainly has some wear), and raised the float just a bit. I also checked the distance from the accel pump linkage arm to the top ring of the air horn - its a little less than the FSM suggests. If it continues to give me trouble, I might try it again with the old accel pump (which worked fine - just figured I'd replace it when I rebuilt it). I also made sure to really drop the top of the carb directly down onto the bowl to ensure the power piston drops directly down onto the PV pistion - I actually think this is pretty critical and isn't guaranteed. I often have to fiddle a bit to get the accel pump to drop into and compress the spring in the well, get the float to fit cleanly into the fuel bowl, and I think I sometimes slid things in a bit from the side - possibly mis-aligning the power piston and valve.

    Initial test run-arounds suggest I moving in the right direction. No longer getting a severe hesitation with heavy throttle - although I really will need to get out on a safe open road for that. There may be a slight hesitation still at full throttle. I also seem to get a slight mis-fire at about 2000 rpm when its just sitting in neutral - but its not noticeable when driving. Going to tweak timing and idle a bit.
     
  10. May 1, 2017
    FinoCJ

    FinoCJ 1970 CJ5 Sponsor

    Denver, CO
    Joined:
    Jul 18, 2013
    Messages:
    1,100
    Well I thought I got it up an running pretty well last week. New PV seemed to take care of carb issues along with raising the float just abit so I get full squirt from the acell pump. That let me get the timing re-worked - the engine seems to like to idle with more initial timing advance than previous to the rebuild. Vac guage and my ear suggest it likes over 10 degrees of initial advance, but that seems to cause a misfire when the mechanical/centrifugal advance and the vac canister also go all in. So I had to back off the initial timing all the way back to 4 BTDC to keep it from having a misfire issue. That seems really low. The centrifugal provides 12 degrees advance when all in, add the 4 of initial and the 12 from the vac can, and that is only 28 degrees of advance when everything is all in. Seems like I could get a bit higher, maybe 8 initial so I am up to 32 all in, but for now that may not be optimal, but its not mis-firing. It doesn't love idling there but it works.

    Of course, just as soon as I thought I was making some progress...I took it out for a longer test drive (drove it to work) and it dies on the interstate a few miles from home. After some fun I got it back home and took a few days to try and diagnose the problem. Seems to be it was the classic issue of a bad condensor. This is a brand new rebuild Cardone distributor that came with points and all. I put in the points and condensor that were working when I took them out a couple years ago to install the pertronix and everything is back to running just like before....for both better and worse.

    Here are the brand freaking new points and condensor in the new distributor that died after 1 month and about 20 miles....Frickin cheap electrical crap...
    [​IMG]

    [​IMG]

    Of course, the only reason I am running points again is I damaged the pertronix ring when I was having issues with my old distributor when I was first installing it back into the the engine after the rebuild. As the central bushing/shaft that the breaker plate slides on was moving up and down - it caused the pertronix magnetic pick-up to get pushed up into the ring on the bottom of the rotor and weights. This rubbing caused some damge to the ring and the magnets in the ring were dislodged.
    [​IMG]

    So I figured I would try my best to epoxy them back in place and see if they would work.
    [​IMG]

    Unfortunately, I think it would have worked fine, but I think I got one of the magnets installed with the polarity reversed. When installed in the distributor, the number 6 plug seems to skip a lot of firing. So, we'll see what is next. Not sure I can get the magnet back out without damage due to the epoxy. Anyone know how critical magnet polarity orientation is for these rings?

    Might be time for a new pertronix set-up, or just go HEI at this time. My intention was just to run points for a while, but it seems they aren't the quality they used to be.
     
    Last edited: May 1, 2017
  11. May 2, 2017
    homersdog

    homersdog Tulsa, Ok Sponsor

    Tulsa, OK
    Joined:
    Jan 8, 2012
    Messages:
    1,242
    FWIW since the time I put HEI in my jeep a couple of years ago my Dauntless has been like a new engine. I never have trouble starting in cold weather and backfiring/stackfiring is a distant memory.

    edit: not that an HEI will solve your backfiring issues without knowing the root cause.
     
    Last edited: May 2, 2017
  12. Dec 1, 2017
    FinoCJ

    FinoCJ 1970 CJ5 Sponsor

    Denver, CO
    Joined:
    Jul 18, 2013
    Messages:
    1,100
    Got a new project I am working on with the jeep - found a BDS 2.5" set of leaves and hardware (although for a 72-75 D30 front so will need different front Ubolts) on CL that were open box but unused.

    My current leaf springs are unknown - kind of assume they are Rancho from the thick leaves in the leaf pack but don't really know - came with jeep from PO. They have enough lift/arch to clear my 33s easily, but they have always been short eye to eye and cause my shackles to hang vertically which is not good for articulation and I can't really get much droop. Additionally, the springs are ridiculously stiff - I can jump on the corner of the front bumper and only get an inch or so of movement - so I don't get much if any articulation when off road. I think the frame flexes more than the springs! As the set-up was basically functional (but certainly not ideal) I have been hesitant to spend money to replace something that 'works' - but couldn't pass up this BDS kit.

    Hopefully the BDS kit will allow for good shackle alignment and be a bit more flexy with a much better ride (within ecj standards of course). My big concern with the BDS kit is will it clear my 33s. As I need to get some new Ubolts for the front D27, I decided to 'test' fit the new springs before buying more hardware to make sure everything will work. I have only put on the front springs at this points - shackles look much better and I can bounce the front end quite alot! Here are a few pics:

    Here is the set:
    [​IMG]

    A comparison of the front springs - the BDS is definitely an 1-1.5 inches longer when unloaded.
    [​IMG]

    Arch is almost the same - but with the softer BDS spring that will probably cause me to loose a bit of lift.
    [​IMG]

    Starting spot - vertical front shackles with old springs:
    [​IMG]

    New front springs - much better shackle alignment!
    [​IMG]

    But here is the problem - and its not totally new or unexpected. As the BDS spring is a bit flatter under load, the already tight clearance between with the 1 piece tie-rod/drang link connection is even worse. Additionally, the spring pack has a clip that is reduces clearance even more and the two will hit each other when turning the wheels left.
    [​IMG]
    [​IMG]

    I had this problem to a lesser degree with the old springs (especially after I went to a shorter shackle), but it wasn't all the time. Now it will always interfere. A two hole knuckle is one solution - but not sure I want to go that route mostly due to the hassle and time to find a knuckle and do the replacement. Maybe its easier than I think. I probably should check the kingpin bearings as well. But I am also considering putting in some caster shims which would be good for caster and would provide a bit more clearance between the steering linkages and springs. Maybe I can get some from Mike.
     
    Last edited: Dec 2, 2017
    ITLKSEZ likes this.
  13. Dec 1, 2017
    ITLKSEZ

    ITLKSEZ Volvophilic

    Post Falls, ID
    Joined:
    Aug 13, 2015
    Messages:
    1,770
    I vote tie rod flip. By what little I can see of your drag link, it looks like it could benefit by being higher?
     
  14. Dec 1, 2017
    FinoCJ

    FinoCJ 1970 CJ5 Sponsor

    Denver, CO
    Joined:
    Jul 18, 2013
    Messages:
    1,100
    The drag link angle is a bit high...causes bump steer and more effort to steer. It goes to the ross bellcrank so cant use a drop pitman arm. I have looked at tie rod flip before...requires reaming out the knuckle hole and welding in a sleeve? I dont have a great way to do either...I can stick metal together but I dont trust it on serious stuff like steering (a big part of my hesitation to try installing a saginaw box).
     
    Last edited: Dec 2, 2017
  15. Dec 1, 2017
    ITLKSEZ

    ITLKSEZ Volvophilic

    Post Falls, ID
    Joined:
    Aug 13, 2015
    Messages:
    1,770
    If you use the "Goferit" brand, it's just a 3/4" drill bit, and even if your welds brake, they can't fall apart. The tightness of the nut holds it all together more than the actual weld.

    Goferit Products!
     
    Bowbender and FinoCJ like this.
  16. Dec 1, 2017
    FinoCJ

    FinoCJ 1970 CJ5 Sponsor

    Denver, CO
    Joined:
    Jul 18, 2013
    Messages:
    1,100
    thats the one i looked at a few years ago....before I spent the last 3-4 years trying to keep this thing running. I can do that now...
     
  17. Dec 1, 2017
    FinoCJ

    FinoCJ 1970 CJ5 Sponsor

    Denver, CO
    Joined:
    Jul 18, 2013
    Messages:
    1,100
    What do you all think is the minimum amount of front fender clearance above the tire that is needed. I have just over 5"...that is about the same gap as between the axle and bumpstop. I think it should be good to go. Looks like mcruff is gonna make me some caster shims if I can get him a measurement asap.
     
  18. Dec 2, 2017
    Muzikp

    Muzikp Sponsor Sponsor

    Sacramento Ca.
    Joined:
    Sep 27, 2016
    Messages:
    275
    I really like the tapered reamer for the tie-rod flip. It was so simple and no welding or parts to wear out. Just my .02
     
  19. Dec 2, 2017
    '74Renegade

    '74Renegade Sponsor Sponsor

    Fair Oaks, CA
    Joined:
    Sep 1, 2005
    Messages:
    913
    I have been using the inserts for a few years and haven't had any problems. Either way it looks like you need to flip it.
     
  20. Dec 2, 2017
    ITLKSEZ

    ITLKSEZ Volvophilic

    Post Falls, ID
    Joined:
    Aug 13, 2015
    Messages:
    1,770
    As a rule of thumb, whatever your lift amount is, you should lower your bump stops by the same amount. A CJ's short front leafspring will over-extend and fatigue if allowed to travel the full 5" when the original design was only supposed to up-travel 2 1/2".

    One should install a lift to expect only more lift, not necessarily more travel, unless installing longer springs, or (usually custom) springs with thinner leaves that can flex further without fatiguing.
     
    FinoCJ likes this.

Share This Page

New Posts