1. Registration trouble? Please use the "Contact Us" link at the bottom right corner of the page and your issue will be resolved.
    Dismiss Notice

Fhead Tuning Issues

Discussion in 'Flat Fender Tech' started by pfmg, May 27, 2018.

  1. Jun 1, 2018
    pfmg

    pfmg Member

    Billerica Mass
    Joined:
    Feb 10, 2010
    Messages:
    199
    Fuel pressure is run thru a regulator, I’ve tried it set from 2 up to 5 with no changes. here is video of it running.
     
  2. Jun 1, 2018
    Daryl

    Daryl Sponsor Sponsor

    Bonney Lake, WA
    Joined:
    May 25, 2006
    Messages:
    2,606
    I would look really carefully for another vacuum leak. Maybe grab another base gasket and double check the fit.
     
  3. Jun 2, 2018
    Glenn

    Glenn Kinda grumpy old man Staff Member Sponsor

    Apopka, Fl
    Joined:
    Sep 21, 2002
    Messages:
    7,941
    Have you tried disconnecting the pcv system and taking a vacuum reading with only that fitting connected to the manifold?
     
  4. Jun 2, 2018
    Glenn

    Glenn Kinda grumpy old man Staff Member Sponsor

    Apopka, Fl
    Joined:
    Sep 21, 2002
    Messages:
    7,941
    Also, I suggest getting the proper, 5/8" wide belt. You should be able to get the right alternator pulley, maybe from a local shop?
     
  5. Jun 2, 2018
    Greevesman

    Greevesman Sponsor Sponsor

    Napa, Ca
    Joined:
    Oct 12, 2014
    Messages:
    209
    It would depend on the degree of flooding, I think.
     
  6. Jun 2, 2018
    pfmg

    pfmg Member

    Billerica Mass
    Joined:
    Feb 10, 2010
    Messages:
    199
    So disconnect the PVC valve, cap it, then go straight into manifold with the vac gauge?
    [​IMG]
     
  7. Jun 2, 2018
    Glenn

    Glenn Kinda grumpy old man Staff Member Sponsor

    Apopka, Fl
    Joined:
    Sep 21, 2002
    Messages:
    7,941
    You don't need to cap it, better to leave it uncapped to help the engine breathe. But yes, straight from the manifold.
     
  8. Jun 5, 2018
    duffer

    duffer Rodent Power Sponsor

    Bozeman, MT
    Joined:
    Sep 17, 2009
    Messages:
    2,317
    I'm with Daryl. I think you still have a vacuum leak. Vacuum wipers? Cracked line or bad connections?
     
  9. Jun 5, 2018
    pfmg

    pfmg Member

    Billerica Mass
    Joined:
    Feb 10, 2010
    Messages:
    199
    I don’t think its a vacuum leak, I’ve checked every where, but anything is possible, i have no vacuum wipers. Here’s another video, what i thought was odd, is the timing mark seems to jump around. I Some more info that’s rather important too, Someone had asked about dwell and it got me thinking about the Petronix unit, so i went and looked at their site, to see if they had any troubleshooting stuff. Instead if found these fancy documents call "Instructions" Son of a B%$#@! if they dont tell you how to install the unit correctly
    Guess i should learn to read instructions first!! Now this might not be 100% of my issues, but i cant see how it helps anything.

    #1, the magnetic pickup, that goes on the lobes of the distributor, comes with green tape around it...i removed it, looked like protective tape. in big bold letters in the instructions is "DO NOT REMOVE THE GREEN TAPE ON THE MAGNETIC PICKUP" [​IMG]

    #2 in the instruction it recommends removing the ballast resistor, the instructions online say you must remove it....needless to say. Mine is still wired in the system.

    #3 don’t use solid core wires, I’m not sure what i have for wires, who knows

    I'll report back when i right my wrongs, and kick myself in the a$$

     
  10. Jun 5, 2018
    PeteL

    PeteL Member Sponsor

    Hills of NH
    Joined:
    Aug 3, 2003
    Messages:
    5,560
    Why I'm a big fan of keeping things original. Others differ.
     
  11. Jun 5, 2018
    PeteL

    PeteL Member Sponsor

    Hills of NH
    Joined:
    Aug 3, 2003
    Messages:
    5,560
    Why I'm a big fan of keeping things original. Others differ.
     
  12. Jun 5, 2018
    Glenn

    Glenn Kinda grumpy old man Staff Member Sponsor

    Apopka, Fl
    Joined:
    Sep 21, 2002
    Messages:
    7,941
    Did you check the vacuum straight off of the manifold?
     
  13. Jun 5, 2018
    Glenn

    Glenn Kinda grumpy old man Staff Member Sponsor

    Apopka, Fl
    Joined:
    Sep 21, 2002
    Messages:
    7,941
    Did you check the vacuum straight off of the manifold?
     
  14. Jun 5, 2018
    pfmg

    pfmg Member

    Billerica Mass
    Joined:
    Feb 10, 2010
    Messages:
    199
    Not yet, I’m waiting till i fix the Petronix issues
     
  15. Jun 5, 2018
    Glenn

    Glenn Kinda grumpy old man Staff Member Sponsor

    Apopka, Fl
    Joined:
    Sep 21, 2002
    Messages:
    7,941
    If your wires say resistor wires then you're good there.
     
  16. Jun 6, 2018
    pfmg

    pfmg Member

    Billerica Mass
    Joined:
    Feb 10, 2010
    Messages:
    199
    Doesn’t really say, says basic core. Either way I had a set of Petronix wires on the shelf, swapped them in

    [​IMG]
    [​IMG]
     

Share This Page

New Posts