1968 Jeepster Commando Steering Ball Joints Replacement Issue

Discussion in 'Jeepster Commando and Commando Tech' started by Nekaf&Jeepsterdude, Jun 29, 2017.

  1. Jun 29, 2017
    Nekaf&Jeepsterdude

    Nekaf&Jeepsterdude 1968 Jeepster Commando, 1951 M38a1C

    The Netherlands
    Joined:
    Aug 22, 2016
    Messages:
    83
    In order to improve steering I have ordered a Tie rod end kit at Partsdude. I have received the kit and have now started unbolting the old ones.
    Currently the steering rods sometimes rub against the leaf springs when I make a turn. I was hoping that the PO had reassembled the steering rods in the wrong position but looking at some pictures of other Jeepsters the rods seem to be in the right position.
    Any suggestions how to assemble the rods to prevent future issues?

     
  2. Jun 29, 2017
    Nekaf&Jeepsterdude

    Nekaf&Jeepsterdude 1968 Jeepster Commando, 1951 M38a1C

    The Netherlands
    Joined:
    Aug 22, 2016
    Messages:
    83
    ok, got them off... I've cleaned the rods a little:

    Any idea why the are bend? Shouldn't they be straight?
     
  3. Jul 1, 2017
    commanlerwrangdo

    commanlerwrangdo Member

    Cleveland, Ohio
    Joined:
    Feb 10, 2014
    Messages:
    388
    Looking at my 67 here in the parking lot, I have no bends in any of my tie rod ends. I have a 19mm clearance above the leaf springs to the tie rods.

    Is your connecting link (adjusting sleeve) between the outer tie rods straight? It should be. The only other way that they can hit or touch other than being bent is bad leaf springs.
     
  4. Jul 2, 2017
    Nekaf&Jeepsterdude

    Nekaf&Jeepsterdude 1968 Jeepster Commando, 1951 M38a1C

    The Netherlands
    Joined:
    Aug 22, 2016
    Messages:
    83
    Ok, thanks for checking! The leaf springs look pretty stock and ok so my guess would be bend tie rods... I will look at it when I re install them and maybe try to bend it back a little... to be continued...
     
  5. Jul 6, 2017
    Nekaf&Jeepsterdude

    Nekaf&Jeepsterdude 1968 Jeepster Commando, 1951 M38a1C

    The Netherlands
    Joined:
    Aug 22, 2016
    Messages:
    83
    Well getting the bushings in is a bit of a struggle... I managed to get the left side in, now over to the passenger side. Front shackle went ok, now trying to replace the rear bushing. My guess is that the right leaf spring is not stock:


    The hole where the bushing is suposed to go is way smaller than the one on the other side...

    Going to bolt it back together. Who has an idea where this leaf spring might come from?
     

Share This Page

New Posts